Give feedback

Disable autolinks inside codeblock in markdown view

In wikipages and markdown viewer, links inside codeblock are converted to a-tags, and protocol is removed. For example: `sudo add-apt-repository -y "deb http://openresty.org/package/ubuntu $(lsb_release -sc) main"` --> sudo add-apt-repository -y "deb openresty.org/package/ubuntu $(lsb_release -sc) main". This makes writing documentation hard.

17 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Teppo Kallio shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        This feature has been annoying before, but now it has become unbearable.

        Previously every part of the documentation which had full URL defined. For example, http://localhost/, was automatically shortened to a link localhost.
        This is an issue, if you have configuration which requires the full URL to be defined. Autolinking also caused issue when references to certain files (my_script.sh my_pyscript.py) were written into
        documentation, as the files were automatically shown as links, this was annoying but still not causing issues (except when the link was clicked).

        Now the issue with configuration examples is gone, as the URLs are shown completely. However now every reference to a file or a package is completly ruined by adding "http://" before the filename.
        The issue seems to be the way how link is determinated. After testing I noticed that the autolink seems use top level domains (https://en.wikipedia.org/wiki/List_of_Internet_top-level_domains).

        Please remove the autolink completely or set it to use only full URLs.

        Ps.
        It is possbile to avoid autolinks by using zero width space (​), but currently this does not work with the code snippets.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I agree! Writing a nice README.md into repository and finding it totally broken is super annoying!

        Even following example:
        ```
        $ qmake example.pro
        ```

        Turns into:
        $ qmake http://example.pro

      Feedback and Knowledge Base